debian/rules
changeset 0 2b3e5ec03512
equal deleted inserted replaced
-1:000000000000 0:2b3e5ec03512
       
     1 #!/usr/bin/make -f
       
     2 
       
     3 # Uncomment this to turn on verbose mode.
       
     4 export DH_VERBOSE=1
       
     5 
       
     6 # This is exported to make the rules for binary-indep and binary-arch
       
     7 # work below
       
     8 export DH_OPTIONS
       
     9 
       
    10 configure: configure-stamp
       
    11 configure-stamp:
       
    12 	dh_testdir
       
    13 	./configure -C
       
    14 	touch configure-stamp
       
    15 
       
    16 build: configure build-stamp
       
    17 build-stamp:
       
    18 	dh_testdir
       
    19 	$(MAKE)
       
    20 	$(MAKE) -C applib pythonapi
       
    21 	touch build-stamp
       
    22 
       
    23 clean:
       
    24 	dh_testdir
       
    25 	dh_testroot
       
    26 	rm -f configure-stamp build-stamp
       
    27 	$(MAKE) distclean || echo "nothing to clean"
       
    28 	dh_clean
       
    29 
       
    30 install: build
       
    31 	dh_clean
       
    32 	dh_testdir
       
    33 	dh_testroot
       
    34 	dh_installdirs
       
    35 
       
    36 	$(MAKE) DESTDIR=`pwd`/debian/dtn/ install
       
    37 	$(MAKE) DESTDIR=`pwd`/debian/python-dtn/ -C applib pythonapi_install
       
    38 
       
    39 # Build architecture-independent files here.
       
    40 binary-indep: build install
       
    41 # We have nothing to do by default.
       
    42 
       
    43 # Build architecture-dependent files here.
       
    44 binary-arch: build install
       
    45 	dh_testdir
       
    46 	dh_testroot
       
    47 	dh_installdocs
       
    48 	dh_installexamples
       
    49 	dh_installlogrotate
       
    50 	dh_install -a
       
    51 	dh_installinit
       
    52 	dh_installman
       
    53 	dh_link
       
    54 	dh_strip
       
    55 	dh_compress
       
    56 	dh_fixperms
       
    57 	dh_installdeb
       
    58 	dh_shlibdeps
       
    59 	dh_gencontrol
       
    60 	dh_md5sums
       
    61 	dh_builddeb
       
    62 
       
    63 binary: binary-indep binary-arch
       
    64 .PHONY: build clean binary-indep binary-arch binary install